Sproutcore Workshop 2011: Unterschied zwischen den Versionen

aus Metalab, dem offenen Zentrum für meta-disziplinäre Magier und technisch-kreative Enthusiasten.
Wechseln zu: Navigation, Suche
K (Gendering ausgebessert)
K (Teilnehmer hinzugefügt, Hinweis bei Ruby zu 1.8 hinzugefügt)
Zeile 31: Zeile 31:
  
 
* Notebook mit Linux oder Mac OS X (Windows geht theoretisch auch, aber auf eigene Gefahr & Recherche)
 
* Notebook mit Linux oder Mac OS X (Windows geht theoretisch auch, aber auf eigene Gefahr & Recherche)
* Ruby 1.8 oder 1.9 bereits installiert (für die build tools)
+
* Ruby 1.8 oder 1.9 bereits installiert (für die build tools) — 1.9 wird bevorzugt, ist noch nicht ganz klar ob 1.8 auch problemlos geht!
 
* Erwähnenswerte JavaScript/ECMAScript-Kenntnisse sind notwendig, jQuery-Kenntnisse von Vorteil, aber nicht unbedingt
 
* Erwähnenswerte JavaScript/ECMAScript-Kenntnisse sind notwendig, jQuery-Kenntnisse von Vorteil, aber nicht unbedingt
 
* Grundlegende Kenntnis der Kommandozeile am jeweilig verwendeten System
 
* Grundlegende Kenntnis der Kommandozeile am jeweilig verwendeten System
Zeile 49: Zeile 49:
 
* @msch
 
* @msch
 
* @anlumo1
 
* @anlumo1
 +
* @smoofles
 
* Hier könnte dein Name stehen!
 
* Hier könnte dein Name stehen!

Version vom 2. April 2011, 23:57 Uhr

Coming soon from @anlumo1 and @msch

Was ist Sproutcore

Bitte auf What is Sproutcore auf der offiziellen Seite nachlesen.

Termine

  • 1. Teil Sonntag, 17.4.2011 15-19 Uhr
  • 2. Teil Sonntag, 24.4.2011 15-19 Uhr

Der 2. Teil baut auf dem 1. auf!

Ort ist natürlich das Metalab (Rathausstraße 6), Raum wird ad hoc bestimmt.

Kosten

Der Workshop selbst ist gratis, Getränke gibts wie üblich vom Metalab (um die üblichen Preise).

Inhalt

  • Installation von Sproutcore
  • Erste Schritte: Wie mache ich ein neues Projekt, wie probiere ich es aus?
  • Projektlayout
  • Konzepte hinter Sproutcore
  • Schrittweiser Aufbau eines Beispielprojekts (siehe unten), mit der Theorie dazwischen immer wenn es aufkommt

Der Workshop wird auf Deutsch/Denglish gehalten!

Vorraussetzungen zum Teilnehmen

  • Notebook mit Linux oder Mac OS X (Windows geht theoretisch auch, aber auf eigene Gefahr & Recherche)
  • Ruby 1.8 oder 1.9 bereits installiert (für die build tools) — 1.9 wird bevorzugt, ist noch nicht ganz klar ob 1.8 auch problemlos geht!
  • Erwähnenswerte JavaScript/ECMAScript-Kenntnisse sind notwendig, jQuery-Kenntnisse von Vorteil, aber nicht unbedingt
  • Grundlegende Kenntnis der Kommandozeile am jeweilig verwendeten System
  • Webbrowser: Firefox, Safari, Chrome, Chromium (andere auf eigene Gefahr), jeweils mit dem Developer-Tool (zB Firebug oder dem Inspector in Webkit) installiert
  • Javascriptfähiger Texteditor (TextMate, vim, emacs, eclipse, ed, …)

Beispielprojekt

Das Projekt wird ein XMPP-basierter Chatclient sein. Dies deckt sehr viele Bereiche von Sproutcore ab, und eignet sich daher gut als Beispiel. Das Ziel ist auch, dass Teilnehmende ihren Client von der Usability her so gestalten können wie es selbst gewünscht wird, und man die Produkte dann trotzdem zusammen ausprobieren kann.

Weiters ist die Serverseite bereits vollständig implementiert (über die BOSH-Erweiterung, die bei so gut wie allen Servern dabei ist), d.h. wir müssen uns nur um den Client kümmern.

Daher sind XMPP-Protokollkenntnisse von Vorteil, aber die werden auch im Workshop so weit erwähnt wie sie notwendig sind. Als Library wird strophe.js verwendet, d.h. man muss nicht alles zu Fuß implementieren.

Liste der Teilnehmenden

  • @msch
  • @anlumo1
  • @smoofles
  • Hier könnte dein Name stehen!